Αναρτήθηκε από: ktogias | Μαΐου 27, 2008

Drupal 6.2 and apache modsecurity at Centos 5

From 04 Feb 2010 ktogias blog has been moved to blog.ktogias.gr. To read updates and new comments and comment on this post please go to: http://blog.ktogias.gr/2008/05/27/drupal-62-and-apache-modsecurity-at-centos-5/

I recently tried to install Drupal 6.2 on a freshlly installed Centos5 server (apache 2.2.3-11.el5_1, php 5.1.6-15.el5, mysql 5.0.22-2.2.el5_1.1 ). After creating the database tables the install script returned a page stating:

The installation has encountered an error.
Please continue to the error page.
An HTTP error 501 occurred.

After some research I found out that the above error was caused by mod_security apache module that was enabled. Editting

/etc/httpd/conf.d/modsecurity_crs_10_config.conf

and setting

SecRuleEngine DetectionOnly

solved the problem. This way I disabled modsecurity to detection only. Maybe there is a better way to handle this problem by leaving modsecurity on and performing per site or per directory configuration.

Advertisements

Σχολιάστε

Εισάγετε τα παρακάτω στοιχεία ή επιλέξτε ένα εικονίδιο για να συνδεθείτε:

Λογότυπο WordPress.com

Σχολιάζετε χρησιμοποιώντας τον λογαριασμό WordPress.com. Αποσύνδεση / Αλλαγή )

Φωτογραφία Twitter

Σχολιάζετε χρησιμοποιώντας τον λογαριασμό Twitter. Αποσύνδεση / Αλλαγή )

Φωτογραφία Facebook

Σχολιάζετε χρησιμοποιώντας τον λογαριασμό Facebook. Αποσύνδεση / Αλλαγή )

Φωτογραφία Google+

Σχολιάζετε χρησιμοποιώντας τον λογαριασμό Google+. Αποσύνδεση / Αλλαγή )

Σύνδεση με %s

Kατηγορίες

Αρέσει σε %d bloggers: